D11541: dirstate-item: use item's property instead of `state` in revert
marmoute (Pierre-Yves David)
phabricator at mercurial-scm.org
Fri Oct 1 09:42:52 UTC 2021
marmoute created this revision.
Herald added a reviewer: hg-reviewers.
Herald added a subscriber: mercurial-patches.
REPOSITORY
rHG Mercurial
BRANCH
default
REVISION DETAIL
https://phab.mercurial-scm.org/D11541
AFFECTED FILES
mercurial/cmdutil.py
CHANGE DETAILS
diff --git a/mercurial/cmdutil.py b/mercurial/cmdutil.py
--- a/mercurial/cmdutil.py
+++ b/mercurial/cmdutil.py
@@ -3352,7 +3352,11 @@
for f in localchanges:
src = repo.dirstate.copied(f)
# XXX should we check for rename down to target node?
- if src and src not in names and repo.dirstate[src] == b'r':
+ if (
+ src
+ and src not in names
+ and repo.dirstate.get_entry(src).removed
+ ):
dsremoved.add(src)
names[src] = True
@@ -3366,12 +3370,12 @@
# distinguish between file to forget and the other
added = set()
for abs in dsadded:
- if repo.dirstate[abs] != b'a':
+ if not repo.dirstate.get_entry(abs).added:
added.add(abs)
dsadded -= added
for abs in deladded:
- if repo.dirstate[abs] == b'a':
+ if repo.dirstate.get_entry(abs).added:
dsadded.add(abs)
deladded -= dsadded
To: marmoute, #hg-reviewers
Cc: mercurial-patches, mercurial-devel
More information about the Mercurial-devel
mailing list