[Updated] D10602: revlog: rename `indexdata` to entry_data
marmoute (Pierre-Yves David)
phabricator at mercurial-scm.org
Tue May 11 17:18:59 UTC 2021
Closed by commit rHG8b549ea4bebf: revlog: rename `indexdata` to entry_data (authored by marmoute).
This revision was automatically updated to reflect the committed changes.
REPOSITORY
rHG Mercurial
CHANGES SINCE LAST UPDATE
https://phab.mercurial-scm.org/D10602?vs=27517&id=27848
CHANGES SINCE LAST ACTION
https://phab.mercurial-scm.org/D10602/new/
REVISION DETAIL
https://phab.mercurial-scm.org/D10602
AFFECTED FILES
mercurial/revlog.py
CHANGE DETAILS
diff --git a/mercurial/revlog.py b/mercurial/revlog.py
--- a/mercurial/revlog.py
+++ b/mercurial/revlog.py
@@ -473,11 +473,11 @@
else:
entry_point = b'%s.i.%s' % (self.radix, self.postfix)
- indexdata = b''
+ entry_data = b''
self._initempty = True
- indexdata = self._get_data(entry_point, mmapindexthreshold)
- if len(indexdata) > 0:
- header = INDEX_HEADER.unpack(indexdata[:4])[0]
+ entry_data = self._get_data(entry_point, mmapindexthreshold)
+ if len(entry_data) > 0:
+ header = INDEX_HEADER.unpack(entry_data[:4])[0]
self._initempty = False
else:
header = new_header
@@ -525,6 +525,7 @@
msg %= (self._format_version, self.display_id)
raise error.RevlogError(msg)
+ index_data = entry_data
self._indexfile = entry_point
if self.postfix is None or self.postfix == b'a':
@@ -564,7 +565,7 @@
elif use_rust_index:
self._parse_index = parse_index_v1_mixed
try:
- d = self._parse_index(indexdata, self._inline)
+ d = self._parse_index(index_data, self._inline)
index, _chunkcache = d
use_nodemap = (
not self._inline
To: marmoute, indygreg, #hg-reviewers, Alphare
Cc: mercurial-patches
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mercurial-scm.org/pipermail/mercurial-patches/attachments/20210511/f46214f0/attachment-0002.html>
More information about the Mercurial-patches
mailing list